log4net 1.2.11 binaries not available from archive.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

log4net 1.2.11 binaries not available from archive.

Jason.La
Hi,

I have an older project that needs to be maintained, and it unfortunately uses log4net 1.2.11 with the old key. 

I've looked here to try and find an official binary of that version, but it doesn't exist: http://archive.apache.org/dist/logging/log4net/binaries/

I've checked the links listed on the old version of the site, here: https://logging.apache.org/log4net/log4net-1.2.11/download.html and those links don't work either. I tried multiple mirrors, and the file is not found on each.

I checked SourceForge, and it does not contain the version.

I've tried the official Nuget repository, but that also does not have v1.2.11, neither the old key or new key.

I tried looking at the FAQ section, looked into Jiří Činčura's blog where he says he published a package for 1.2.11, and his blog links back to the official Nuget repo, which does not have a v.1.2.11.

Where would I find a safe, trustworthy binary for log4net 1.2.11? If I downgrade to 1.2.10, would I be missing out on bug fixes? I assume moving to 2.x contains breaking changes, so it doesn't look like an option.

Thanks,
Jason

Jason La
Software Developer
Student Affairs Information Systems
Email: [hidden email]
UC Santa Barbara