[jira] [Commented] (LOG4J2-1867) jackson-databind dependency missing in the configuration document

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[jira] [Commented] (LOG4J2-1867) jackson-databind dependency missing in the configuration document

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/LOG4J2-1867?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15964546#comment-15964546 ]

ASF subversion and git services commented on LOG4J2-1867:
---------------------------------------------------------

Commit 024acaf3e30a59c746506f9c9d92083fb3a35325 in logging-log4j2's branch refs/heads/java9NoMultiRelease from [~mikaelstaldal]
[ https://git-wip-us.apache.org/repos/asf?p=logging-log4j2.git;h=024acaf ]

LOG4J2-1867 Fix JSON and YAML config examples and dependency info


> jackson-databind dependency missing in the configuration document
> -----------------------------------------------------------------
>
>                 Key: LOG4J2-1867
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-1867
>             Project: Log4j 2
>          Issue Type: Documentation
>          Components: Documentation
>    Affects Versions: 2.8.1
>            Reporter: James Jithin
>            Assignee: Mikael StÃ¥ldal
>             Fix For: 2.9
>
>
> Was following the link:
> http://logging.apache.org/log4j/2.x/manual/configuration.html
> to configure log4j2 with yaml.
> The following links:
> http://logging.apache.org/log4j/2.x/maven-artifacts.html
> http://logging.apache.org/log4j/2.x/manual/configuration.html#YAML
>  asks to import the following dependencies:
> <dependencies>
>   <dependency>
>     <groupId>org.apache.logging.log4j</groupId>
>     <artifactId>log4j-api</artifactId>
>     <version>2.8.1</version>
>   </dependency>
>   <dependency>
>     <groupId>org.apache.logging.log4j</groupId>
>     <artifactId>log4j-core</artifactId>
>     <version>2.8.1</version>
>   </dependency>
> </dependencies>
> <dependency>
>     <groupId>com.fasterxml.jackson.dataformat</groupId>
>     <artifactId>jackson-dataformat-yaml</artifactId>
>     <version>2.8.6</version>
> </dependency>
> But not
> <dependency>
> <groupId>com.fasterxml.jackson.core</groupId>
> <artifactId>jackson-databind</artifactId>
> </dependency>
> which is a requirement.
> Enabling debug mode didn't point out about missing classes com.fasterxml.jackson.databind.ObjectMapper and com.fasterxml.jackson.databind.JsonNode which are mentioned in YamlConfigurationFactory. Such messages on missing classes is really going to help in resolving issues at the earliest. Please add the missing dependency to the YAML section. I see that it is provided for JSON configuration, but missed for YAML.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...