is log4j-api-java9 available.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

is log4j-api-java9 available.

Sandeep Gupta
Hello,

 When executing my code in docker image (openjdk-11.0.6), I get
NoClassDefFoundError error StackLocator$FqcnCallerLocator.
 This class seems to be in log4j-api-java9 but I am not able a build
for it. What should be done.

Thanks
S

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: is log4j-api-java9 available.

Matt Sicker
That module is combined into log4j-api at build time. The version specific
code is inside META-INF if you look inside the jar.

On Fri, Feb 28, 2020 at 05:28 Sandeep Gupta <[hidden email]> wrote:

> Hello,
>
>  When executing my code in docker image (openjdk-11.0.6), I get
> NoClassDefFoundError error StackLocator$FqcnCallerLocator.
>  This class seems to be in log4j-api-java9 but I am not able a build
> for it. What should be done.
>
> Thanks
> S
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
> --
Matt Sicker <[hidden email]>