Re: UHG0948-VR-Operating System Compatibility for Application : Apache Log4j 1.2.8

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: UHG0948-VR-Operating System Compatibility for Application : Apache Log4j 1.2.8

Ralph Goers

Ralph

On Dec 9, 2016, at 12:26 AM, HariKrishna Beerangi <[hidden email]> wrote:

Hello,
 
As part of planning an operating system upgrade for our customer, we are researching the OS supportability status of one or more  of your company’s applications.  Unfortunately, we could not locate this information on your website.  In order to help our joint customer make the most informed decision regarding the supportability of your application in their enterprise, we request your assistance in providing support information on your application as per the details below.
 
Current OS Version
Windows 7
Current Application Suite Name
Apache Log4j 1.2.8
 
Current Application Suite Packages
 
Requested Information:
 
Is the application version listed above supported on:
 
 
 
Operating System
Yes / No
  Windows 10
 
 
 
 
If not supported, is the application version listed above compatible on:
Operating System
Yes / No
Windows 10
 
 
 
 
Is a newer version of your application supported on:
 
 
 
Operating System
Application Version
Windows 10
 
 
 
 
Documentation Links / Reference
 
Support Contact Email
 
Sales Contact Email
 
 
 
Thank you for your assistance!
 
Regards
Harikrishna Beerangi
Consultant
Microsoft Global delivery
Manyata embassy Tech park
Nagawara, Karnataka, Bangalore , India-560045

Reply | Threaded
Open this post in threaded view
|

Re: UHG0948-VR-Operating System Compatibility for Application : Apache Log4j 1.2.8

Matt Sicker
Log4j 1.x is EOL and is no longer supported. It is, however, supported by all versions of Windows running Java up to version 8. Java 9 will no longer support Log4j 1.x, so that's the real end of life.

On 9 December 2016 at 01:26, HariKrishna Beerangi <[hidden email]> wrote:

Hello,

 

As part of planning an operating system upgrade for our customer, we are researching the OS supportability status of one or more  of your company’s applications.  Unfortunately, we could not locate this information on your website.  In order to help our joint customer make the most informed decision regarding the supportability of your application in their enterprise, we request your assistance in providing support information on your application as per the details below.

 

Current OS Version

Windows 7

Current Application Suite Name

Apache Log4j 1.2.8

 

Current Application Suite Packages

 

Requested Information:

 

Is the application version listed above supported on:

 

 

 

Operating System

Yes / No

  Windows 10

 

 

 

 

If not supported, is the application version listed above compatible on:

Operating System

Yes / No

Windows 10

 

 

 

 

Is a newer version of your application supported on:

 

 

 

Operating System

Application Version

Windows 10

 

 

 

 

Documentation Links / Reference

 

Support Contact Email

 

Sales Contact Email

 

 

 

Thank you for your assistance!

 

Regards

Harikrishna Beerangi

Consultant

Microsoft Global delivery

Manyata embassy Tech park

Nagawara, Karnataka, Bangalore , India-560045

 




--
Matt Sicker <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: UHG0948-VR-Operating System Compatibility for Application : Apache Log4j 1.2.8

Gary Gregory-4
I'm sure someone will fork it to provide the one fix...

Gary

On Dec 9, 2016 8:34 AM, "Matt Sicker" <[hidden email]> wrote:
Log4j 1.x is EOL and is no longer supported. It is, however, supported by all versions of Windows running Java up to version 8. Java 9 will no longer support Log4j 1.x, so that's the real end of life.

On 9 December 2016 at 01:26, HariKrishna Beerangi <[hidden email]> wrote:

Hello,

 

As part of planning an operating system upgrade for our customer, we are researching the OS supportability status of one or more  of your company’s applications.  Unfortunately, we could not locate this information on your website.  In order to help our joint customer make the most informed decision regarding the supportability of your application in their enterprise, we request your assistance in providing support information on your application as per the details below.

 

Current OS Version

Windows 7

Current Application Suite Name

Apache Log4j 1.2.8

 

Current Application Suite Packages

 

Requested Information:

 

Is the application version listed above supported on:

 

 

 

Operating System

Yes / No

  Windows 10

 

 

 

 

If not supported, is the application version listed above compatible on:

Operating System

Yes / No

Windows 10

 

 

 

 

Is a newer version of your application supported on:

 

 

 

Operating System

Application Version

Windows 10

 

 

 

 

Documentation Links / Reference

 

Support Contact Email

 

Sales Contact Email

 

 

 

Thank you for your assistance!

 

Regards

Harikrishna Beerangi

Consultant

Microsoft Global delivery

Manyata embassy Tech park

Nagawara, Karnataka, Bangalore , India-560045

 




--
Matt Sicker <[hidden email]>

Reply | Threaded
Open this post in threaded view
|

Re: UHG0948-VR-Operating System Compatibility for Application : Apache Log4j 1.2.8

Matt Sicker
And then they get to have fun trying to compile and release it. :)

On 9 December 2016 at 11:05, Gary Gregory <[hidden email]> wrote:
I'm sure someone will fork it to provide the one fix...

Gary

On Dec 9, 2016 8:34 AM, "Matt Sicker" <[hidden email]> wrote:
Log4j 1.x is EOL and is no longer supported. It is, however, supported by all versions of Windows running Java up to version 8. Java 9 will no longer support Log4j 1.x, so that's the real end of life.

On 9 December 2016 at 01:26, HariKrishna Beerangi <[hidden email]> wrote:

Hello,

 

As part of planning an operating system upgrade for our customer, we are researching the OS supportability status of one or more  of your company’s applications.  Unfortunately, we could not locate this information on your website.  In order to help our joint customer make the most informed decision regarding the supportability of your application in their enterprise, we request your assistance in providing support information on your application as per the details below.

 

Current OS Version

Windows 7

Current Application Suite Name

Apache Log4j 1.2.8

 

Current Application Suite Packages

 

Requested Information:

 

Is the application version listed above supported on:

 

 

 

Operating System

Yes / No

  Windows 10

 

 

 

 

If not supported, is the application version listed above compatible on:

Operating System

Yes / No

Windows 10

 

 

 

 

Is a newer version of your application supported on:

 

 

 

Operating System

Application Version

Windows 10

 

 

 

 

Documentation Links / Reference

 

Support Contact Email

 

Sales Contact Email

 

 

 

Thank you for your assistance!

 

Regards

Harikrishna Beerangi

Consultant

Microsoft Global delivery

Manyata embassy Tech park

Nagawara, Karnataka, Bangalore , India-560045

 




--
Matt Sicker <[hidden email]>




--
Matt Sicker <[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: UHG0948-VR-Operating System Compatibility for Application : Apache Log4j 1.2.8

Remko Popma
In reply to this post by Ralph Goers
Hello Harikrishna Beerangi,

Log4j 1.2.8 is End of Life since August 2015. 
Log4j 1.2 is the equivalent of Windows 2000 in the Java logging world. 

To answer your question, Log4j 1.x is _not_ supported on Windows 10 or any other version of Windows. 
It is compatible with Java versions up to Java 8, but will no longer work with Java 9. 

We recommend all applications that use Log4j 1.x to upgrade to the latest version, currently Log4j 2.7. 
For anyone requiring assistance doing so, there are user and developer mailing lists (http://logging.apache.org/log4j/2.x/mail-lists.html), and an online issue tracker (https://issues.apache.org/jira/browse/LOG4J2). 

We hope this answers your question, but feel free to follow up. 

Kind regards,
Remko Popma

Sent from my iPhone

On 9 Dec 2016, at 16:26, HariKrishna Beerangi <[hidden email]> wrote:

Hello,

 

As part of planning an operating system upgrade for our customer, we are researching the OS supportability status of one or more  of your company’s applications.  Unfortunately, we could not locate this information on your website.  In order to help our joint customer make the most informed decision regarding the supportability of your application in their enterprise, we request your assistance in providing support information on your application as per the details below.

 

Current OS Version

Windows 7

Current Application Suite Name

Apache Log4j 1.2.8

 

Current Application Suite Packages

 

Requested Information:

 

Is the application version listed above supported on:

 

 

 

Operating System

Yes / No

  Windows 10

 

 

 

 

If not supported, is the application version listed above compatible on:

Operating System

Yes / No

Windows 10

 

 

 

 

Is a newer version of your application supported on:

 

 

 

Operating System

Application Version

Windows 10

 

 

 

 

Documentation Links / Reference

 

Support Contact Email

 

Sales Contact Email

 

 

 

Thank you for your assistance!

 

Regards

Harikrishna Beerangi

Consultant

Microsoft Global delivery

Manyata embassy Tech park

Nagawara, Karnataka, Bangalore , India-560045