New user solaris 2.8 compile issues

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

New user solaris 2.8 compile issues

Atul Pandya
I untar'd the log4cxx tar file and now trying to compile it.

I see the following errors:
./autogen.sh
./autogen.sh: libtoolize: not found
./autogen.sh: aclocal: not found
./autogen.sh: autoheader: not found
./autogen.sh: autoconf: not found
./autogen.sh: automake: not found

The INSTALL file says to run autogen first followed by ./configure and then
make all etc.

Is this the right order? What am I missing?

Any env variables to be set?
Thanks
Atul

Reply | Threaded
Open this post in threaded view
|

RE: New user solaris 2.8 compile issues

Raymond Lau
I have run into a similar problem when I compiled on cygwin.  The
problem was that there's no symbolic link to the actual utility like
Autoconf, automake,...  So check if those binaries/executable do exist
on your machine.. It could be under a different name like automake.X.Y
where X and Y are part of the version number. The utility should be
located in the normal path like /usr/bin or /usr/local/bin ...  

-----Original Message-----
From: news [mailto:[hidden email]] On Behalf Of Atul Pandya
Sent: Monday, May 16, 2005 10:59 AM
To: [hidden email]
Subject: New user solaris 2.8 compile issues

I untar'd the log4cxx tar file and now trying to compile it.

I see the following errors:
./autogen.sh
./autogen.sh: libtoolize: not found
./autogen.sh: aclocal: not found
./autogen.sh: autoheader: not found
./autogen.sh: autoconf: not found
./autogen.sh: automake: not found

The INSTALL file says to run autogen first followed by ./configure and
then make all etc.

Is this the right order? What am I missing?

Any env variables to be set?
Thanks
Atul