Is log4net 2.0.8 compatible with x64 ?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Is log4net 2.0.8 compatible with x64 ?

Vu Ho Tien

Hi everybody,

My software need to be upgraded to build on X64 environment according to the software development plan, this software is using log4net 2.0.8 version. Is this version compatible with x64 ?

I have read the guidelines for migrating 32-bit managed code to 64-bit at https://docs.microsoft.com/en-us/previous-versions/dotnet/articles/ms973190(v=msdn.10), then I reviewed log4net 2.0.8 source code and found that it was using the DLLImport so I'm worried that there might be a potential risk of using log4net on x64 environment. Please help me !

Thanks, all



Disclaimer

The content of this email is confidential and intended for the recipient specified in message only. It is strictly forbidden to share any part of this message with any third party, without a written consent of the sender. If you received this message by mistake, please reply to this message and follow with its deletion, so that we can ensure such a mistake does not occur in the future.

This email has been scanned for viruses and malware by proper antivirus software. Providing a safer and more useful place for your human generated data. specializing in; security, archiving and compliance.